Challenge
X-Charge is not functioning properly & these are some troubleshooting steps prior to calling Open Edige Support.
Cause
X-Charge is displaying errors or not functioning as expected.
Solution
Option 1: Cannot Connect to Server
1. Restart X-Charge service on FCD-DC-UTIL01.
a. Services to restart
i. X-Charge Security
ii. X-Charge Server
b. Use Power Shell Script.
Get-Service -ComputerName FCD-DC-UTIL01 -ServiceName xcs* | Restart-Service
c. Restart FCD-DC-UTIL01
Option 2: Unable to Process Credit Cards
1. If there is a Public Key problem delete Key named XWebE2EPublicKeys.
a. x86
HKEY_CURRENT_USER\Software\X-Charge\XWebE2EPublicKeys
b. x64
HKEY_CURRENT_USER\Software\X-Charge\Wow6432Node\XWebE2EPublicKeys
Option 3: X-Charge Crashing for Unknown Reasons
1. Change Default Printer
a. Exit out of X-Charge
b. Change Default printer to anything then change it back.
c. Go back into X-Charge and test
Option 4: Test if Credit Card Can Be Run
1. Test Credit Card Information
a. Credit Card Number: 4444 2222 2222 2222
b. Expiration: 1223
c. CVV: 123
More Information
If these do not help, please contact OpenEdge Support 800.774.6462 (Option 2) or support@openedgepay.com
Comments